Using standard formats
You can use catalogue standard formats to export data from your PlentyONE system to a file in the formats CSV, JSON, TXT or XML. There are a variety of different standard formats for exporting different types of data. Not all types of data can currently be exported using catalogues. Until standard formats are available for all types of data, you can continue using the FormatDesigner for any data that is not currently supported by catalogues.
The following standard formats are currently available:
-
Newsletter recipients
-
Order document
-
Document
1. Understanding the catalogue menu for standard formats
When you open the menu Data & Plugins » Catalogues, the first thing you see is the catalogue overview. You can get to know this catalogue overview here.
Click on a catalogue in order to open its detail view. The layout of this menu is the same for all standard formats, so it should look like this:
Tip: Your catalogue looks different? Then you probably opened a catalogue with a marketplace format instead. Marketplace formats used to export item data to specific markets and price portals and are elaborated on here instead.
1.1. Toolbar
The toolbar provides quick access to various actions you can perform with the currently opened catalogue:
save Save |
Saves any changes you made to the current view of the catalogue. |
||||
preview Preview |
Creates a preview of the export data. The preview contains the first 5 data rows of the export file. Important: The preview function is not available for all catalogue formats. |
||||
Asynchronous download |
Starts a manual download of the catalogue data. The export is carried out as a background process, and the export file is available for download in your system’s Notifications once the process is finished. |
||||
play_circle Live download |
Starts a manual download of the catalogue data. The download starts immediately in a new tab, and the file is automatically saved to your computer if you allowed your system to display popups in your browser. |
||||
playlist_play Status |
Opens the menu Data & Plugins » Catalogue export status and filters the list for this catalogue. This view allows you to check the status of all exports of the catalogue that have been initiated so far. |
||||
more_vert More |
Shows additional actions:
|
1.2. Navigation
When you open a catalogue, the view Data sources is shown by default. Use the navigation to switch to other views of the catalogue. Every catalogue using a standard format has the following views to switch between:
Settings |
This menu contains all settings for the catalogue. The settings are grouped into four sections:
|
Data sources |
This menu is shown when you open the catalogue. In this view, you select the data sources that you want to export. |
filter_alt Filter |
Add filters to only export specific records. Tip: The number of filters that you activated for a catalogue is always displayed next to this menu item. Template filters, i.e. filters that are applied by default, are not included in the count.
|
Own data sources |
Own data sources are currently not available for most exports. |
[#menu-export-fields] === Available PlentyONE data fields On the left-hand side of the mapping list, all PlentyONE data sources that you can export are listed in groups. To add a data source to the export, hover over the data source with your cursor and click on the + icon that appears on its right-hand side.
Tips: * Use the field Search data source to quickly find and add data sources. * In addition to the data sources listed, you can also add own values to the export. The same value is then exported for each record. * Add the option Formula to recalculate numerical values during the export. For example, you could use this option to update all exported variation prices during the export. [#menu-added-fields] === Selected data sources On the right-hand side of the mapping list, any data sources you have added to the catalogue so far are shown. These data sources will be exported to your file when an export is carried out. If no data sources have been added yet, then the message “No data sources were selected” will be displayed instead. On the right-hand side of the Data fields view, any data sources you have added to the catalogue so far are shown. These data sources will be exported to your file when an export is carried out. If no data sources have been added yet, then the message “No data sources were selected”. will be displayed instead. In the following screenshot a few data sources have already been added:
Tips: * You can move the data sources using drag-and-drop. This will change the order in which the data sources are displayed in the export file. * You can optionally change the export keys of the data sources. “Export keys” are the names of the column headers as they will appear in your export file. Keep in mind that every export key used in the catalogue must be unique. * You can optionally add fallback data sources. If the primary data source provides an empty or invalid value, then the system will check the fallback data sources in sequence for usable values instead. [#create-catalogue] == Creating catalogues Creating a standard format catalogue is relatively simple. Proceed as follows: [.instruction] Creating a catalogue: . Go to Data & Plugins » Catalogues. |
|Setting |Explanation
|Name
(required)
| Enter a name for the catalogue.
| Marketplace
(required)
| Select the option Standard format.
| Export type
(required)
| Select a format type from the drop-down list. Different format types are used to export different kinds of data.
|Category
(required)
| Select a format from the drop-down list.
Note: For most format types only one format is selectable in this field. If the format type you selected offers multiple formats, then you can find an explanation of those formats on the format type’s manual page.
[#catalogue-settings] == Setting up the catalogue export Once you have created a catalogue you can customize it to suit your individual data export needs. This chapter explains the different customisation options for standard format catalogues in further detail. IMPORTANT: Certain format types offer additional customisation options in the Settings menu of the catalogue. These additional options are explained on the manual pages dedicated to those format types. [#format-settings] === Carrying out the format settings The format settings are used to specify the file format in which the data is exported and how the export file is formatted. [.instruction] Configuring the settings: . Go to Data & Plugins » Catalogues. |
|Setting |Explanation
| File name
a| Enter a file name. The exported file is saved with this name.
Tip: The file extension is automatically added during the export.
As such, enter the file name without a file extension.
File extensions are for example .csv and .txt.
Tip: You can use placeholders in the file name. Placeholders are automatically replaced by additional information relating to the file name during export.
The following placeholders are available:
Examples for using placeholders:
| Format | Select the file format for the export.
Possible values:
-
CSV
-
CSV - Array to JSON
-
JSON
-
TXT
-
XML
| Field separator | Specify which character should be used to separate the contents of the file into individual data fields.
Possible values:
-
Comma = ,
-
Semicolon = ;
-
Pipe = |
-
Tabulator = ␉
| Text delimiter | Specify which character should be used to separate text strings into individual values.
Possible values:
-
"
-
'
| Encode special characters ()
| If you activate this option, unicode characters (e.g. umlauts: ä, ö, ü) will be exported in encrypted form.
Note: This option is only available for the formats JSON and CSV - Array to JSON.
| Line break | How do you want to handle line brakes in the export file?
Possible values:
-
Carriage return
-
Line feed
-
Carriage return an line feed
| Header is included | Activate the option if you want the export file to contain a header line. The export keys are used as headings for the columns.
| Decimal separator | Select the character that is used to separate the decimal part of a number from its integer part.
Possible values:
-
Comma
Example:20,00 Euro -
Period
Example:20.00 Euro
[#export-settings] === Carrying out the export settings The export settings determine where your export file is saved. [.instruction] Carrying out the export settings: . Go to Data & Plugins » Catalogues. |
|Setting |Explanation
| Limit
| In this field you can optionally enter an upper limit for the amount of data sets that are included in the export.
Tip: You can use the Preview or Live download functions to determine how your data is organised in the export file and which data sets are excluded by the limit.
| Skip empty files | If this toggle is activated, then empty files will not be exported to the target location.
| Provisioning
| Where do you want to save the export?
Important: This setting does not export any data to markets.
| Server
(for FTP, SFTP, FTPS, SFTP extended)
| Enter the server where you want to save the export.
Note: Do not enter a protocol prefix.
Some examples for protocol prefixes are ftp:// and ftps://.
| Port
(for FTP, SFTP, FTPS, SFTP extended)
| Enter a port or use the default setting.
Recommended port settings:
-
For FTP and FTPS = Port 21
-
For SFTP = Port 22
| User name
(for FTP, SFTP, FTPS, SFTP extended)
| Enter the user name for the server.
| Password
(for FTP, SFTP, FTPS, SFTP extended)
| Enter the password for the server.
| Path
(for FTP, SFTP, FTPS, SFTP extended)
| Enter the path to a location on your server where the export files should be saved.
Note: If you use SFTP, enter the complete path.
| Test connection
(for FTP, SFTP, FTPS, SFTP extended)
| Tests the server settings that you entered:
-
Can PlentyONE connect to the server?
-
Can an export file be saved at the storage location?
Tip: A test file is saved at the storage location. This test file is called plentymarkets_ConnectionTestFile.txt.
| Transfer | Select an interval in which the export should be carried out automatically.
| Schedule: times
(Only appears when Schedule: times is selected)
| Click into the field. In the drop-down list shown, select one or more points in time. The export is carried out at these times.
| Weekdays
(for Transfer ≠ Never)
| By default, all weekdays are selected. To deactivate exports for specific days of the week:
-
Click in the field Weekdays.
→ A drop-down list with weekdays is shown. -
Uncheck the checkbox for one or more weekdays (icon:check_box_outline_blank).
→ Exports are only started on weekdays with a check mark ().
Tip: The setting Weekdays is only shown if you select an interval or schedule for the setting Transfer.
[#download-settings] === Setting up download links In the Download settings of the catalogue you can generate download links. These download links give you direct access to the export file. * The admin link only allows you to access the exported file if you are currently logged into your PlentyONE System as an admin. * You can limit how your data can be accessed via the public link by using the Use version and/or Use token options. NOTE: The catalogue must be active to create an export file. The export file can only be accessed after the first export. [.instruction] Setting up the download: . Go to Data & Plugins » Catalogues. |
|Setting |Explanation
| Shop URL a| Select the domain name that should be used to generate the download links. Each client managed in your system will offer two options in the list of available domain names:
-
The client’s domain name.
Note: If you assigned a name to the client, then that name will be displayed instead of the domain name. -
A domain name based on the client’s Plenty ID (e.g. if its PID is 12345, then the domain name will be
p12345.my.plentysystems.com)
Note: If this option is picked, then the domain will also be included in the links shown in the Admin link and Public link fields.
| Receive notifications | Activate to get a notification at the top right of the system once the export is completed.
2+^| Options for admin link
| Admin link | An admin link is automatically created for each file. This admin link only allows you to access the exported file if you are currently logged into your PlentyONE System as an admin.
Tip: Click on the icon to the right (content_copy) to copy the URL to your clipboard.
| Use version | If this option is active, then a new admin link is generated every time any catalogue settings or mappings are changed. Export files created after the change are made available via this new admin link, while the export file created before the change remains available via the old link for 15 days. Tip: Do not activate this option if you always want to access the most current export file via the same admin link.
2+^| Options for public link
| Activate options |
Tip: In the row Public link, click on the icon to the very right (content_copy) to copy the URL to your clipboard.
| Use version | If this option is active, then a new public link is generated every time any catalogue settings or mappings are changed. Export files created after the change are made available via this new public link, while the export file created before the change remains available via the old link for 15 days. Tip: Do not activate this option if you always want to access the most current export file via the same public link.
| Use token | If this option is active, then a randomly generated security token is appended to the public link. A new security token can be generated at any time, and links containing the current security token can be used to access export files created by the catalogue.
| Security token | Click on the symbol on the right () to generate a new token.
Tip: The current token is automatically added to the public link in the Public link field.
| Public link | Shows the public link. After the first export, the file can be accessed by anyone who knows this link.
Tip: In the row Public link, click on the icon to the very right (content_copy) to copy the URL to your clipboard.
[#data-export] == Selecting data for export Now decide what PlentyONE data you want to export with this catalogue. This is how the information in this chapter is structured: * Adding data sources for export * Removing data sources from the export * Filtering export data [#add-fields] === Adding data sources to export Now it’s time to decide which PlentyONE data source data sources you want to export from PlentyONE with this catalogue. To do so, add the data sources to the export as described below. [.instruction] Adding data source to the export: . Go to Data & Plugins » Catalogues. You can also use a variety of more complex export features that are explained in the collapsible boxes below: [#optional-fallback] [.collapseBox] .Export a different data source if the first data source is empty (Add fallback data source) — Fallback data sources can be used to ensure that a particular type of data is exported, even when the preferred source of that data fails to provide it. Here is how they work: * If the primary data source provides a usable value for a record, then that value is exported and the fallback data sources linked to the primary data source are ignored. * If the primary data source does not provide a usable value for a record, then the fallback data sources are checked for usable values in sequence, going from top to bottom. If a usable value is found, then that value is exported for that record and any remaining data sources are ignored. If no usable value is found in any of the data sources, then no value is exported for that record. [.instruction] Adding fallback data sources: * Initial setup: . Below the data sources, click on + Add fallback data source. Note the following logic for fallback data sources: * Even if you assign one or more fallback data sources, the value of only one field is exported. * For each record, the PlentyONE data sources are checked in the order in which you mapped them, i.e. first the one at the top of the list, then the one below it etc. * Tip: You can use the data source Own value as a fallback data source in order to ensure that a value is exported for every record. — [#optional-own-value] [.collapseBox] .Optional: Export the same value for every record (Own value) — The data source Own value can be used to export the exact same value for every record. [.instruction] Exporting an own value: . In the list of available data sources, select the data source Own value near the top of the list. * The data sources are to be combined during the export. * The combined values of the data sources are inserted into a single column of the export file. * The character separating the values is specified with the option Separator. [.instruction] Combining data sources: * Initial setup: . Next to the marketplace data source, click on + Add data source (). IMPORTANT: This feature is not available for all export formats yet. Additionally, it can only be used with data sources that return numerical values. [.instruction] Recalculating numerical values: . Go to Data & Plugins » Catalogues. If you would like your data to be presented in a different order in the export file you can rearrange it by dragging individual data sources or whole data rows around in the list with your cursor. * To move a single data source: Point your mouse at the data source and drag and drop it to the new position. * To move a whole data row: * Click on the symbol (drag_indicator) on the left side and drag and drop the row to the new position. — [#delete-fields] === Removing data sources from export In the *Mapping tab of a catalogue with a standard format you can remove individual or several data sources at once. [.instruction] Removing data sources from export: . Go to Data & Plugins » Catalogues. [#filter-data] === Filtering export data You can use filters to limit the data that should be exported. [.instruction] Adding a filter: . Go to Data & Plugins » Catalogues. [#export-data] == Exporting catalogue data There are several ways to export the catalogue data: * Export a preview of the first 5 data rows * Automatically export data in regular intervals * Manually starting a one-time export [#preview] === Creating an export preview After you have selected data sources for export, you can test the catalogue export using the preview function. This preview function allows you to download the first 5 data rows of the export. IMPORTANT: The preview function is not available for all catalogue formats. [tabs] ==== Show a preview in the catalogue:: + — [.instruction] Showing a preview in the catalogue: . Go to Data & Plugins » Catalogues. [.instruction] Creating a preview from the catalogue list: . Go to Data & Plugins » Catalogues. [#activate-catalogue] === Activating automatic catalogue export You have added all data sources that you want to export? Then your data is ready to be exported. Activate the catalogue in order to enable the automatic export schedule you set earlier. IMPORTANT: Make sure that you have carried out all necessary export settings. Otherwise, no data is exported. [.instruction] Activating automatic catalogue export: . Go to Data & Plugins » Catalogues. [#manual-export] === Starting a manual export :author: team-plenty-channel Have you added at least one data field to the export? Then download the catalogue data manually. The format of the download file depends on the format settings of the catalogue. You can export data in CSV, TXT, JSON and XML files. There are two ways to manually export the catalogue data: [cols="1,3a"] |
| Asynchronous download | The export runs in the background. Once the download is completed, you download the export file from the Notifications (notifications).
| Live download
| The file is downloaded to your computer automatically. You can follow the export progress in real time.
However:
-
Do not close or reload the browser tab or the PlentyONE tab Data export while the export is in progress. If you do so, the export will be cancelled.
-
The import can run into a timeout if you try to import large amounts of data. If that happens, the download is cancelled. For lots of data or if a timeout occurs, use the asynchronous download instead.
[tabs] ==== Starting an asynchronous download:: + — For asynchronous downloads, the export runs in the background. So note that there will be no window for downloading the file straight away. Even exporting small amounts of data will take around 30 minutes. When the export is completed, you can download the export file from the Notifications (notifications). [.instruction] Starting an asynchronous download: . Go to Data & Plugins » Catalogues. * When you start the live download, a new browser tab opens. In this browser tab, the PlentyONE tab Data export is shown. Do not close or reload the browser tab and the PlentyONE tab Data export while the export is in progress. If you do, the export stops and is cancelled. * You can start live downloads for several catalogues at the same time. However, you can only start a new live download for the same catalogue once the current export is complete. * The import can run into a timeout if you try to import large amounts of data. If that happens, the download is cancelled. For lots of data or if a timeout occurs, use the asynchronous download instead. [.instruction] Starting a live download: . Go to Data & Plugins » Catalogues. [TIP] .Stopping a live download ====== Do you want to stop a live download? No problem: * In the tab Data export, click on Cancel export (highlight_off) at the top right. [faq] == FAQ: Questions and answers [.collapseBox] .Which catalogue format do I need for which export? — * You want to export data from PlentyONE to a CSV, JSON, TXT or XML file? You need a catalogue with standard format. * You want to export item data to markets? Use a catalogue with marketplace format. — [.collapseBox] .What does “Export Key” mean? — The “Export Keys” are the names of the column headers, as they will appear in your export file. Every “Export Key” needs to be unique. * Negative example: You use the data sources Item ID and Variation ID. You give both “Export Keys” the name “id”. As a result, the export file only includes one of the two IDs. A column is missing in the export file. * Positive example: You use the data sources Item ID and Variation ID. You give one “Export Key” the name “VariationID” and the other “ItemID”. image::data:catalogue-export-keys.png[] — [.collapseBox] .How should an export key be structured? — The Export Key is the name of the column header that will be shown in your export file. * Each export key can only be used once in each catalogue. * Negative example: You use the data sources Item ID and Variation ID. You give both “Export Keys” the name “id”. As a result, the export file only includes one of the two IDs. A column is missing in the export file. * Positive example: You use the data sources Item ID and Variation ID. You give one “Export Key” the name “VariationID” and the other “ItemID”. image::data:catalogue-export-keys.png[] — [.collapseBox] .Only the word “Array” is exported. Why? — If you export a file in CSV or TXT format, then you might only see the word "Array" instead of the actual export values. This happens e.g. when exporting multiple images or when exporting multi-selection properties. This is a known issue and will be fixed in the future. Possible workaround 1: Would it be an option for you to download a JSON or XML file instead? With these file types, you can see the actual export values. . Click on Settings. . Scroll down to the section Format settings. . Select JSON or XML from the drop-down list Format. . Save () the settings and download the file (file_download). * Caution: If you want to revise the file and import it again. Note that the import tool only accepts the file types CSV and TXT. Possible workaround 2: Export the data with the tools FormatDesigner and Elastic Export instead. — [.collapseBox] .Can I revise the file and import it again? — Yes. Export the file in CSV or TXT format. Then revise the file and import it again. Note that the import tool only accepts the file types CSV and TXT. — [.collapseBox] .No file is available through the catalogue’s download URL. Why? — 1. Is the catalogue active? 2. Has an export taken place? Check the export settings. 3. Did you use the right URL? — [.collapseBox] .The download URL leads to the message "Unauthenticated." instead of to file. Why? — You used the admin URL. However, you are not logged into your PlentyONE system as an admin user. 1. Log in as an admin user. 2. Generate a public URL. The file can always be accessed with this URL. — [.collapseBox] .Why can I not see the catalogues? — Users with back end access rights can only see catalogues if an admin gave them access. . Find someone who has administrator rights for the PlentyONE system. . This person will open the menu Setup » Settings » User » Rights » User. . Then they will open your user account and activate the necessary rights: * *Data > Data exchange > Export > Catalogue > Show . Save () the settings. — [.collapseBox] .I want to import, export, delete, copy or restore catalogues. How do I do that? — You can find information on how to manage your catalogues here: * Copy catalogues * Delete catalogues * Restore a previous catalogue version * Restore a deleted catalogue * Export catalogues * Import catalogues * Assign rights for back end users — |


